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Layers & Transformations 
Layers

Layers are one of the most important features of Photoshop and this lesson 
will focus entirely on how to work with layers.

Layer Concepts
Layers are like sheets of transparent plastic that you can paint on and adjust. 
Like sheets of transparent plastic in the physical world, layers can be added, 
removed, repositioned, or stuck together. But better than plastic sheets, a 
layer’s transparency can be easily changed as well as how it blends with the 
layers beneath.

Shown below is an example of a layers palette, the resulting image, and how 
layers “stack” to produce the image:

Getting to Know the Layers Palette
Below is the Layers palette (If you do not see the Layers palette in 
Photoshop, then go to the Window menu and select Show Layers)

Layer lock options

Layer opacity 
adjustment

Layer blend 
selection

Show/Hide Layer

Layer Mode
Layer preview

Layer name

Layer style

Add mask
Create 
layer set

Add/Copy Layer

Trash

Add new 
fill/adj. 
layer
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Layers & Transformations
When an image is first opened in Photoshop, it is automatically named 
“Background,” has its opacity set to 100%, and is locked so no Layers palette 
options (Blend mode, Opacity, locks) can be applied.

When creating a new image, the background can be set to the current 
background color, white, or transparent.

!
                    Warning WARNING: Photoshop files saved in the PSD (PhotoShop Document) file 

format will retain layer information, so save your work in the 
PSD format. You can always come back to it later and edit the 
file, and save the image in a different format. 

Add/Copy, Name, Reorder, Hide/Show, & Remove Layers

Add/Copy Layer
To add a new layer, click the Add Layer button at the bottom of the Layers 
palette. This will create a new, blank, and transparent layer.

To copy a layer, drag a layer to the Add Layer button and a duplicate layer 
appears with a slightly different name (original name + “copy”).

Name a Layer
To help keep layers straight, it’s good practice to give each layer a name. 
Follow these steps to name a layer: 

1. Hold down the <Alt> key and double-click the layer you want to name.
Result: A dialog box appears to enter the name of the layer and, 
optionally, give the layer a color code to help in organizing layers.

2. Click OK to finalize the name and color of the layer.
Result: The layer’s name and/or color code is changed. 

Reorder Layers
To change layer order, drag a layer higher or lower on the Layer Palette’s 
layers stack. The order of the layers stack matches their order in the image, 
with the top layer being highest and the bottom layer being the background.

Hide and Show Layers
To hide a layer, click the “eye” button (Show/Hide layer). The layer turns 
invisible and the “eye” disappears.

To restore a hidden layer, click the empty view Show/Hide Layer button 
again. This will show the hidden layer and the “eye” again.
Note: If no layers are visible or if nothing is under a transparent part of a 
layer, Photoshop displays a checkerboard pattern.

Remove a Layer
To remove a layer, either select the layer you want to remove and click the 
palette’s Trash button, or drag and drop the layer onto the Trash button.
3-3



Layers & Transformations 
Linking, Merging, and Flattening Layers

Link Layers
Linking layers is useful if you want two (or more) layers to move in unison. 
To use the sheets of transparent plastic analogy, linking layers is like gluing 
two (or more) plastic sheets together so they can move as a single sheet. This 
is useful for text and a drop-shadow, or a layer object and an associated glow 
effect layer. 

To link one layer with another, click one layer to make it the active layer. 
Next, click the Layer Mode button of the second layer you want to link with. 
The second layer’s Layer Mode button changes to a “chain” icon, indicating 
the layer is now linked to the other layer.

To unlink a layer, click the layer’s “chain” Layer Mode button. This breaks 
the link between the selected layer and the layer(s) it was linked with.

Note: Other than sharing a common position on the screen, linked layers are 
independent of each other; you cannot apply a special effect or edits to 
both linked layers at the same time (to do so, you would have to merge the 
two layers).

Merge Down/Merge Linked
To merge a layer with the layer directly underneath, use the keyboard 
shortcut <Ctrl> + E (if this is done on a linked layer, the linked layers will 
merge to become one layer).

Flatten Visible Layers
To flatten all the image’s visible layers and leave the hidden layers alone, use 
the keyboard shortcut <Shift> + <Ctrl> + E. 

Flatten Layers
To merge all the image’s layers into a single layer go to the Layers menu and 
select Flatten. 

De-Fringing a Layer’s Edges
Often, after editing, a layer has an unsightly “fringe” or “halo” around its 
edges. This can be removed by using one of the Layer > Matting tools. 

Defringe removes a specified number of pixels from the layer’s edges.

Remove Black Matte removes any dark pixels from the layer’s edges.

Remove White Matte removes any white pixels from the layer’s edges.
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Layers & Transformations
Layer Blending, Opacity, and Styles
Blending, Opacity, and Styles provide useful subtle and not-so subtle effects.

Blending
As with the paint tools in the previous chapter (page 2-16), there’s a plethora 
of blending modes that can be applied to a layer. Blends affect how the 
selected layer interacts with the layer below it. 

Opacity
Use this to adjust the layer’s transparency. A layer with 100% opacity is 
completely opaque and the layer underneath cannot be seen. A layer with 0% 
opacity is completely transparent and the layer underneath can be clearly 
seen. Between these two extremes is varying degrees of transparency, thus 
you can make a layer so faint one can barely see it or make a layer show just 
a hint of the layer beneath. 

Opacity can be adjusted by clicking the upsidedown triangle next to the 
Opacity field and using the horizontal slider or by clicking in the Opacity 
field and typing the number you want (between 0 and 100%).

Layer Style
A layer style is a pre-made special effect that can applied to a layer. Unlike a 
filter effect, you can also make adjustments after it has been applied to a 
layer. Another difference between styles and filters is that styles can be used 
in combination. On the left side of every Style dialog box, there are check 
boxes that you can click to select other Styles to use. 

The basic styles listed in the Styles menu include:

Blending Options

Drop Shadow

Inner Shadow

Outer Glow

Inner Glow

Bevel & Emboss

Satin

Color Overlay

Gradient Overlay

Pattern Overlay

Stroke
3-5



Layers & Transformations 
Locking Layers
A selected layer can be locked so it cannot be modified, repositioned, or 
deleted. On the Layers palette above the stack of layers are four lock 
checkboxes. From left to right, those lock settings are:

Lock transparent pixels (checkerboard icon)
Stops any modification to the transparent area of a layer. This is useful if 
you want to restrict edits to the non-transparent parts of a layer.

Lock image pixels (paint brush icon)
Stops any modification to the image other than position, opacity, and 
blend mode. This is useful if you want to protect a layer from being 
accidently modified. This option also locks the layer’s transparent pixels.

Lock position (vertical and horizontal arrows icon)
Keeps the layer in its current position so it cannot be moved.

Lock all (padlock icon)
Stops ALL modification to the layer. A locked layer cannot be modified 
or removed.

Editing Layers
Unless it is locked, a layer can be edited using any tool in the Toolbox palette 
and any special effects filter in the Filters menu. 

Note: To utilize the full range of tools and filters, it is best to edit your graphic 
in RGB mode and when finished, convert it to CMYK if necessary.

Exercise: Big City, Big Bear
The goal of this exercise is to take a photo of Fred Bear and make him look 
gigantic by placing him behind a city skyline by applying and editing layers.

Example files: Q:\Department\Photoshop\exercises\exercise_3seattle.tif and 
Q:\Department\Photoshop\exercises\exercise_3fred_bear.psd

1. Open an existing Photoshop photo of Fred Bear and a photo of Seattle. 
Drag and drop the Fred Bear photo into the Seattle picture.

Result: The Fred Bear photo appears on top of the Seattle photo.

2. Close the Fred Bear photoshop file.

3. Press <Alt> and double-click the Fred Bear layer to display the Layer 
Properties box, name it “Fred Bear” and click OK to set the layer name.

Result: The layer’s name changes to “Fred Bear.”

Continued on the next page…
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Layers & Transformations
4. Press <Alt> and double-click the Background layer.

Result: The layer’s name changes to “Layer 0” and the layer’s padlock 
icon disappears (the layer is unlocked and can now be edited).

5. Press <Alt> and double-click the “Layer 0” layer to display the Layer 
Properties box, name it “Seattle” and click OK to set the layer name.

Result: The layer’s name changes to “Seattle.”

6. In the Layers palette, drag the Seattle layer to the “Add New Layer” 
button at the bottom.

Result: A new layer appears named “Seattle copy”

7. In the Layers palette, drag “Seattle copy” over the Fred Bear layer.

Result: The “Seattle copy” layer appears above the “Fred Bear” layer 
and Fred Bear disappears (covered up by the “Seattle copy” layer).

8. In the Layers palette, click the View Layer (eye) icon for the “Seattle” 
and “Fred Bear” layers to hide the layers.

Result: The eye icons for the two layers disappear (because “Seattle 
copy” completely covers both lower layers and is visible, no changes are 
visible in the image).

9. Select the Magic Wand tool from the Toolbox and in the Tool Options 
bar, set its tolerance to 25 and make sure the Anti-Alias and Contiguous 
boxes are checked.

10. Hold down the <Shift> key and click parts of the sky above Seattle and 
the distant hills. 

Result: Most, if not all, of the sky and distant hills are selected.

Note: The Magic Wand isn’t perfect and some parts of the city may be 
selected as well. Use the Magnifying Glass icon to zoom in on an 
area, hold down <Alt> (subtract from selection) and use the Lasso 
tool to deselect the building parts that the Magic Wand included.

Continued on the next page…
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Layers & Transformations 
11. Go to the menu Select > Feather, set the Feather radius to 1 pixel, and 
click OK.

12. Press <Delete>.

Result: The selected area of the “Seattle copy” layer disappears, 
showing the Photoshop checkerboard pattern.

Note: If the mountain in the background still remains, then use the Eraser to 
remove it.

13. Press <Ctrl> + D to turn off the selection.

14. Click the View Layer icon for the “Fred Bear” and “Seattle” layers.

Result: The two layers appear. The resulting image shows Fred Bear 
looming large peeking over buildings. This looks good, but could be 
better by making the light on Fred Bear more closely match his 
surroundings.

15. Drag the Fred Bear layer to the Add New Layer button at the bottom to 
make a copy.

Result: A new layer “Fred Bear copy” appears.

Continued on the next page…
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Layers & Transformations
16. Go the menu Filter > Render > Lighting Effects.

Result: The Lighting Effects dialog box appears.

17. Set the light Style to “Soft Omni,” reposition the light in the preview box 
to Fred Bear’s left side so his left side is illuminated, and click the top 
white box to bring up a color selection box and set the light color to a 
light yellowish-orange color (like sunlight at dusk). Click OK to exit the 
Lighting Effects box and apply the filter.

Result: The lighting of “Fred Bear copy” changes and approximately 
matches that of the light falling on the city.

18. Save the Photoshop file to your personal folder.
3-9
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Transformations

To resize (scale), rotate, skew, distort, or flip a layer or selection, use one of 
the Edit menu options, Free Transform or Transform.

Free Transform
Edit > Free Transform
Freehand transforms a selection or layer with the mouse. To scale a 
transformation, click a corner handle box on the edge of the selection or layer 
and move the mouse while holding the mouse button down. To distort the 
layer or selection, press <Ctrl>. The mouse pointer changes and you can grab 
the corner handles to reshape the layer or selection. Finalize the 
transformation by double-clicking the image or cancel it by pressing <Esc>.

Transform
Edit > Transform 
To adjust with precision, edit the Options bar fields at the top of the screen. 

Finalize the transformation by clicking the checkbox button (or press 
<Enter>) or cancel it by clicking the X button (or press <Esc>).

!
                    Warning WARNING: A transformed selection is “cut” from its layer and any empty 

space will be transparent or filled with the background color.

See the table below for a brief description of each Transform option:.

Transformation Description
Again Repeats the last Transform action performed. 
Scale Resizes the selected area or layer. 

Note: To keep the resizing proportional, press <Shift> while 
resizing freehand.

Rotate When editing freehand, clicking inside the layer or selected 
area and moving the mouse lets you reposition the area or 
layer, while selecting a side or corner handle lets you rotate 
the layer or selection.

Skew All three of these transformation options are similar to each 
other in that they let you twist, stretch, and distort a selected 
area or layer. However they all differ from each other in 
subtle ways. Skew twists a selection, Distort twists and 
scales a selection, and Perspective adjusts the view of a 
selection or layer as if it were a 3-dimensional object.

Distort
Perspective

Rotate 180°
Rotate 90° CW
Rotate 90° CCW

Rotates the selection or layer 180°, 90° clockwise, or 90° 
counter-clockwise.

Flip Horizontal
Flip Vertical

Flips the selection or layer horizontally or vertically.
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Layers & Transformations
Tips for using Layers

Some brief tips for using layers:

Layers are good for giving yourself room for error and experimentation. 
Copy a layer (and then hide the original layer) and make your edits until 
satisfied with the results. If you make a mistake and Undo or Step 
Backward isn’t enough, then just delete the modified layer, recopy the 
original layer, and try again. 

To resize, rotate, skew, distort, or flip a layer use the Transform options 
(see page 3-10).

Instead of performing a 3-step process of copying/cutting a selected area 
to the clipboard, make a new layer, and then pasting it to the new layer, 
do this instead: 
With your selected area defined go to the menu Layer > New > Layer via 
Copy or Layer via Cut. With one click you can copy or cut the selection 
to a new layer.

When doing composite images (making a single image from two or more 
separate images), here are some important points to remember:

• Keep backgrounds simple (for the image that is going on top of 
another layer), that way less effort is spent on clean-up.

• Isolate elements on separate layers for more flexible editing.
• Ensure that the elements you want to combine are on the same scale 

with each other (unless one’s goal is to not have scales match, like a 
giant bear towering over Seattle).

• A subtle factor that makes a fake image more believable is the 
behavior of light. As you saw in the “Big City, Big Bear” exercise, 
having one element’s lighting match the other makes for a more 
believable image. Discrepancies in lighting are one of those small, 
subtle things the viewer can subconsciously pick up on and know 
immediately that “it just doesn’t look right.”
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Layers & Transformations 
Assignments

1. Photoshop “Dress Up”
Open the Photoshop file in 
Q:\Department\Photoshop\assignments\assignment_3a.psd. 
Use the Layers palette to rearrange, reposition, view, modify, or hide the 
file’s various layers. When done, flatten layers and save the image to the /
Photoshop folder in your personal folder in a different file format.

Extra challenge: Add a new layer (either a whole new layer or a modified 
copy of an existing layer) to make a new element to add to the picture. 

2. Bad Fake Photo
Start your future in tabloid illustration now! Scan a couple photos of a 
person, place, or thing and combine them using layers in whatever way 
you want to. 

3. Line Drawing
When a document requires an picture of an object (handheld unit, U-Scan 
station, etc.), a photo is easy to make but often doesn’t reproduce very 
well when printed. A line drawing reproduces better, conveys essential 
information, and looks more professional. 

Open the sample image 
Q:\Department\Photoshop\assignments\assignment_3c.tif, 
and make a tracing of the image. Save it to your personal folder.

Hints:
• To simulate tracing paper, make a white layer above the image and 
reduce its opacity enough to see the edges of the picture beneath while 
still being able to see the black lines of the outline on the “tracing paper.” 
• Trace the image with any paint/draw tool you want, but two 
recommended tools are the Polygon Lasso tool (outline an area and use 
Stroke to make the line) and the Line tool (draw the outline then go to 
Layer > Rasterize > Shape to convert the vector outline to a bitmap). 
• When done, save the Photoshop file to your personal folder, set the 
“tracing paper” layer’s Opacity to 100%, flatten layers, and save the final 
image with a different name and/or file format to your personal folder. 
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